Club409

The best damn waste of time!

Calling on you computer nerds

Oscar
Total posts: 1323
below the file name change it from "Text Documents (*.txt)" to "All Files (*.*)"
Shawn
Total posts: 1260
I tried that and it still renames it to a text file
torzan
Total posts: 310
notepad sucks.

use vim

or just save it close notepad rename it reopen in notepad continue with your life. notepad should keep your extension from there on out.
mwinter
Total posts: 4180
vim blows goats.

also if you haven't already done it i strongly suggest you *dont* hide extensions of known file types. Once you can see the extension for all files renaming something to .pl is trivial. To do this open any folder in windows explorer (e.g. just open up My Computer) then go to tools -> folder options click the View tab and uncheck the box:



then click the "apply to all folders" button.
SmoovB
Total posts: 1097
In any microsoft product I know of use the "all files" on the pull down and then put your intended name in quotes:

"your_stupid_document.pl"
torzan
Total posts: 310
it's not vim's fault you have the mental capacity of a raisin.
Shawn
Total posts: 1260
I thought that too and I renamed it several times using the all files and even renamed it the file after saving and it still kept the .txt . I might have some weird setting turned on.
mwinter
Total posts: 4180
Don't give me so much credit -- I certainly haven't had a successful career in the
acelxix
Total posts: 2247
I know this works because I use notepad to create HTML files.

I just opened notepad and saved "Shawn is a goat.pl" by specifying "All Files". The file extension is .pl. I saved another file as "omg wtf" and it saved it as "omg wtf.txt" by default. Then I did a "Save As" renamed the file to "omg wtf.pl" making sure to select "All Files". The file saved just fine with .pl as the extension. Notepad works just fine.

If that doesn't work and you don't want to change the setting Matt suggested just go to cmd and use rename:
c:\> rename "omg wtf.pl" "omg.wtf"

Keep in mind that notepad recognizes .pl files atleast it's the default editor on my computer. So don't be mistaken by the icon. It's a stretch but this is a mundane task so that might be causing some confusion.

btw: Pico FTW lol.
Shawn
Total posts: 1260
I use notepad to save .html files as well and it still didn't work. I will try again tonight.